last update 18.november 2016:
BananaPi Test in MSK144 with WSJTx 1.7rc2

update 13.october 2016: Cubieboard2
with ARMBIAN (fldigi,linrad,wsjtx)

update 6.january 2016: BananaPi
running OPENWEBRX with RTL-SDR @ 1MHz bandwidth

update 3.january 2016: Cubieboard2
running MSHV 1.06 from LZ2HV

update 10.september: 2015 Banana PI
as monitoring RX with RTL-SDR/Linrad/WSJTx 1.6.1-devel)

update 24.december 2014: Cubieboard2/Banana PI
as monitoring RX with FCD Pro+)

update 6.december 2014: BANANA PI with Mate Desktop
and Debian Jessie running WSJTx r4743, testing K9AN WSPR decoder on CB2 and BPi)

update 18.october 2014: BANANA PI kernel update
and running FREEDV, CUBIEBOARD2 running FREEDV on Debian Wheezy)

update 21.september 2014:  BANANA PI arrived and tested,

update 23.july 2014: CUBIEBOARD2 running DEBIAN JESSIE
and WSJTx 1.4r4182 and 1.3r3673 with MATE DESKTOP)


my goal for this work:
after some playing with the Cubieboard 1 i bougth in the end of 2013
an Cubieboard 2 also, to let run it for some hamradio applications.

The CUBIEBOARD 2 has the same pcb and outline like the CUBIEBOARD 1 but it uses an
DualCore CPU@ 1GHz  the Allwinner A20.

The Cubieboard 2 has after delivery an installed Android 4.2.2 on the internal flash memory.
For my use i installed the CUBIEEZ Distribution 1.0 on an 8GB Micro SD Card Class 10.
CUBIEEZ is a special made DebianWheezyDistribution for the Cubieboard 2
and is based on Debian Linux 7.1.

After setting up the network interface and the language settings i made an system update,
downloaded and compiled WSPR on the same way like on the Cubieboard 1
and then i installed FLDIGI from the Debian ARM source.
But there came a problem....!
The line in (capture) mixer was not seen using the alsamixer command.
After some time of recherche i got the information that the script.bin 
in the boot partition have to be modified. After replacing the script.bin with a modified version the
capture mixer can be seen with the alsamixer command , but i got no good audio on the input.
Maybe there is something going wrong on my board during looking to get line in running.
So i have ordered a second Cubieboard 2 and it has the same error.
(Maybe anyone can help? pse INFO)
update: 15. march 2014 -> PROBLEM IS SOLVED look in the text below

In the meantime i am using an USB audio dongle (soundblaster) which is working well.
So here are some screenshots with the cubieboard 2 running some hamradio applications.

CUBIEBOARD2 running PSK31 (with F
After this first tests i saw that there is enough performance to run some more.
So the idea came to use the board as monitoring RX for WSJTx and
also as server for the RTL-SDR dongles.
To get run it on WSJTx there is not many information avaliable on the web.
So i tried my luck and got some information from Franco  IW2DHW in
the wsjt yahoo group.
After some try and error i got it running. 
Franco many many thanks for the fast and good help.
In the compiled ARM version there is the soft decision decoder kvasd not availiable.
So i contacted Joe Taylor K1JT for some help. Joe many many thanks.
The kvasd file for ARM (tested on Cubieboard2) can be downloaded from...

So the board can run now with full decoder performance and and in both
modes JT65 and JT9 at the same time.

CUBIEBOARD2 running WSJTx 1.1r3496

update: 8 March 2014
CUBIEBOARD2 running_as RTL-SDR Server
After installing the rtl-sdr software some more tests were done.
I tried out to run 2 RTL-SDR sticks in parallel with 2.048 Mbit sample rate.
Both sticks are sampling from USB to the LAN Interface and using different ports.

device1: RTL-SDR Stick with R820T and up-converter for shortwave
device 0: RTL-SDR stick with E4000 for VHF and UP

The load from every RTL-SDR instance is about 12-13% so some more should be possible,
but i think there are some limitations on the USB interface to get more sticks to run.
On the client side for decoding I used SDR Radio V2 for the R820T stick and
GQRX or GNURADIO Companion for the E4000 stick.
SDR Console  V2 connected via LAN to the Cubieboard2 RTL-SDR Server

to the Cubieboard2 RTL-SDR Server (running in parallel to SDR Console V2)

GQRX connected via LAN to the Cubieboard RTL-SDR Server
(running in parallel to SDR Console)


update: 15.March 2014
On 15th march2014 I changed to the Qbee-X distribution based on
UBUNTU 12.04 (for ARM). It uses newer sunxi-kernel 3.4.79 but also needs a
modified script.bin to use the line in.
But a nice surprise... the line in works if the alsamixer is set correctly!
Here are the alsamixer settings for correct operation.


now WSJTx,WSJT,FLDIGI and WSPR can be used without an external soundcard!

Cubieboard2 with Qbee-X Distro running WSJTX
Cubieboard2 with Qbee-X Distro running WSJT
Cubieboard2 with Qbee-X Distro running WSPR

update: 22.March 2014
I tried to use Cubian-LXDE version based on Debian Wheezy 7.4.
I made some changes for my amateur radio use and also changed 
the kernel from 3.4.75 to the kernel 3.4.79.
Some more versions of WSJT could be compiled and testet.
I got running:
WSJT 7.06r1938 (after manual patch)
WSJT 7.07r2031 (after manual patch)
WSJT 9.02r2231 (after manual patch)
WSJT 9.3r2589 and  WSJT 9.5r3633

Cubian-Screen with my hamradio applications

update: 28.March 2014
Now I tried SSTV. I got running
QSSTV 7.1 (from debian packages with analog SSTV and FAX)
QSSTV 8.1.17 and QSSTV 8.2.4 with analog SSTV and digital SSTV DRM !! (nice)


update: 31.March 2014
Now some SDR work again. LINRAD 4.00 from SM5BSZ could be compiled.
I got it running with the internal soundcard @ 48 kHz and with the
RTL-SDR @ 1.024MHz sample rate.  Some more test are to do
 to let run it on SDR-IQ or maybe with higher sample rates with RTL-SDR.

Xlinrad running on Cubieboard2 with RTL-SDR on 2m band with 1MHz bandwidth
how to optimize CPU load for LINRAD on the CB2 (for SSB mode as example):
1. change the default values in  par_ssb file

First FFT bandwidth (Hz) [500]
First FFT window (power of sin) [1] 

2.change the parameters for CPU use in par_userint
Process priority [1]
Max blocked CPUs [1]

This changed the CPU load at 1.024MHz sample rate to around 60 to 80%.
If you want to use higher sample rates give First FFT bandwidth a bigger value.
The result after optimization of the parameters !

Xlinrad running on CB2 on 20m with R820T stick and converter @ 1.024MHz
A complete manual how to setup LINRAD can be found on
ON4KHGs homepage.

update: 3.April 2014
Some more SDR work now with my SDR-IQ. It was not easy to get it running because
it looks a little bit complex under Linux because of some driver effects.
James N2ADR gave some hints on his page.
But I could not compile the ft245 driver today, maybe I will try later again.
So I used the ftdi_sio USB-serial driver for this setup.
At first some tests with QUISK version 3.6.2 from the Debian arm package.
Then the other versions QUISK 3.6.14 and 3.6.16 running good.
The usable SDR-Bandwith without audio dropouts is about 55kHz.

Cubieboard 2 running QUISK with SDR-IQ

After then again LINRAD and the SDR-IQ.
Here it was possible to use 111kHz sample rate without audio dropouts.

Cubieboard 2 running SDR-IQ and Xlinrad at 111KHz bandwidth
and finally ... testing CUTESDR. It works via IP (loopback) connection
and with 55kHz bandwidth and low audio dropouts.

Cubieboard 2 running SDR-IQ and CuteSDR 

update: 15.April 2014
here is a (incomplete) list of the tested HAMRADIO applications which
are running now on my Cubieboard 2

FlDIGI 3.21.48
FlDIGI 3.21.79
FlDIGI 3.21.80
FlDIGI 3.21.81
FlLOG 1.1.8 
FLRIG 1.3.15 


WSPR  4.0r3015
WSPRx 0.8r3058
WSPRx 0.9r3621

WSJTX 1.1r3496
WSJTX 1.1r3505

WSJT 7.06r1938
WSJT 7.07r2031
WSJT 9.02r2231
WSJT 9.3r2589
WSJT 9.5r3633
WSJT 10r3814

CuteSDR 1.05

QUISK 3.6.2
QUISK 3.6.14
QUISK 3.6.16

QSSTV 8.1.17
QSTTV 8.2.4


Linrad 4.00 (config for soundcard)
Linrad 4.00 (config for SDR-IQ)
Linrad 4.00 (config for RTL-SDR)

GLFER (under test)
GMFSK (under test)
LINPSK1.2 (under test)

update: 21.April 2014
 I could manage to run GNURADIO 3.7.3 on the board.
The compile process needs some hours.
Additionally I could compile the OSMOCOM source block 
for the use with RTL-SDR, SDR-IQ and other hardware.
GNURADIO is running but only uses one CPU in the moment
so the performance is bad.  CPU optimization needs a recompile of
I tried it with the following command line option of cmake.

cmake -DCMAKE_CXX_FLAGS:STRING="-march=armv7 " -DCMAKE_C_FLAGS:STRING="-march=armv7 " ../

The result looks better now both CPUs are in use.

Cubieboard 2 running GNURADIO COMPANION 3.7.3


GQRX ( could be tried out,
it is running on low SDR bandwidth around only 16kHz for audio decode in USB mode.

Cubieboard 2 running GQRX with SDR-IQ


  update: 23.July 2014
Debian Jessie will go out in 2015 so some preview what will work there...
  I used the Debian Jessie Image from
I installed MATE-Desktop, Slim and Fluxbox .... for a tryout ...
also newer SUNXI-kernels are working well.
Development System QT5 is now in USE ...
So it is possible to use the newest Versions of WSJTx.

Cubieboard 2 running Debian Jessie WSJTx 1.4r4182 and WSJTx 1.3r3673 on Mate Desktop
 Cubie Jessie mate

update: 21.September 2014
Banana Pi arrived some days ago. It uses the same CPU like the Cubieboard2...
so most of work done for the Cubieboard2 before, will also run here.
I made a first test with the BananaPI Lubuntu image, copied my compiled
Cubieboard2 versions to the BananaPi and it works.
After removing the microphone and setup an external input socket
I checked WSJT,WSJTx,WSPRx and WSPR.
Also the A20 kernel updates from
DANAND running. (actual version is 3.4.103c)
  (correction see below)
Additionally I tried a 20% overclock of the CPU to 1.2GHz and it looks ok.
Banana PI running WSJT10 on Lubuntu

Banana PI running WSJTx r3505 on Lubuntu

Banana PI running WSPRx r3058 on Lubuntu

 but I saw only low activity on then main QRG 14.236 MHz.

FREEDV running on Cubieboard2 with Debian Jessie

update: 18.October 2014
I tried out the new CUBIAN X1 Image.
It uses MATE-Desktop and Debian Backports.
So it is possible to use some newer packages. FREEDV could be found
and tried out under Cubian X1 (DebianWheezy).

Cubieboard2 running CubianX1, MATE and FREEDV

For the BananaPi I found a better working kernel update from "slovenia" and 
the FREEDV package which can be transferred from Cubieboard2 to the BananaPi.
After installing 2 additional packages it worked also with Lubuntu14.04.

  BananaPi running Lubuntu with Kernel 3.4.104 and FREEDV

update: 6.December 2014
Igor (Slovenia) has released on 3.december 2014 new
Debian Jessie Images for Cubieboard/Cubietruck and BananaPi.

BananaPi Jessie Image (v1.6 Kernel 3.4.105)
Cubieboard Jessie Image (v2.9 Kernel 3.4.105)

Howto install a minimal graphical environment with Mate Desktop with this image?
So i tried it with the BananaPi and Cubieboard2.

1. download Jessie image and put it on SD Card
2. login as root and change your password
3. adduser maybe "bananapi"
4. reboot
5. login as root
6. install graphical environment (slim,Mate) and some setup tools
apt-get install xorg
   apt-get install slim
   apt-get install mate-desktop-environment
   apt-get install synaptic
   apt-get install console-setup
7. setup for keyboard layout and other local settings
   dpkg-reconfigure keyboard-configuration
   dpkg-reconfigure tzdata
   dpkg-reconfigure locales
   dpkg-reconfigure console-setup
8. switch off DPMS (no video anymore after 10 min timeout)
      add a file as root

which content  
Section "Monitor"
    Identifier "LVDS0"
    Option "DPMS" "false"
Section "ServerLayout"
    Identifier "ServerLayout0"
    Option "StandbyTime" "0"
    Option "SuspendTime" "0"
    Option "OffTime" "0"
9. reboot  and login in SLIM
10. install your needed packages with synaptic
Some newer programs for amateur radio use are now
in the official sources of Debian Jessie
RTL-SDR and other tools for HackRF, BladeRF

and some more
After some work your desktop can look like this
BananaPi running Debian Jessie with Kernel 3.4.105 and WSJTx r4743

Testing K9AN WSPR decoder with WSPRx (r4178)

K9AN released some time ago an modified WSPR decoder.
Instructions how to use and compile can be found here.
I compiled the decoder and renamed (replaced) the original file "wsprd" in the
wsprx_install directory with the modified version from K9AN... and it works.
For comparision of decoder performance i let run 2 instances of WSPRx r4178 
on the Cubieboard2 or on the BananaPi.
(left window K9AN, right window K1JT decoder)

BananaPi running with WSPRx  r4178 Decoder K9AN/K1JT

update:24.December 2014
The Funcube Dongle Pro + is a nice toy to play with and can make a
complete monitoring SDR for the A20 boards with low power.
So i checked it with nice results...
I got finally working:
LINRAD (in combination with WSPRx,WSJTx)
The audio bridge is made via pulseaudio server.
also working
Note: I used the original firmware of the FCD Pro+
(not the RPi Version).
So the useable bandwidth ist 192 kHz.

BananaPi running LINRAD and WSJTx at the same time

update: 10.September 2015 offered in august 2015 RTL-SDR sticks with R820T2 tuner, TCXO and
an SMA input connector. I ordered and got very good results for decoding  JT65/JT9 after a first test.
It looks the stick has much better performance because of the good LO and the new tuner.

RTL-SDR with R820T2 and internal TXCO

so the BananaPi is now running with RTL-SDR and converter for shortwave,
Linrad 4.06 (250kHz samplerate) and WSJTx 1.6.1-devel r5882
as monitoring receiver

update:3. January 2016
Compile of MSHV V1.06 from LZ2HV as ARM Version on my ORDOID C1.
But it is not working there because of soundcard issues.(ALSA)
So I ported the binary to the Cubieboard2 and it is running.
MSHV is supporting the following weak signal modes


Cubieboard 2 running MSHV1.06 with low CPU-load (1st test FSK441)

update: 6.January 2016
OPENWEBRX from HA7ILM was transferred to the BananaPi and working with
1MHz bandwidth on the BananaPi with RTL-SDR and shortwave converter.
The CPU load is about 50-60%.

BananaPi running OPENWEBRX on 40m Band

update: 13.October 2016
After some time i made a new test with the actual ARMBIAN 5.20 on the Cubieboard2.
I recompiled fldigi, WSJTx, linrad and GQRX and testet it with the RTL-SDR(tcxo).

Cubieboard 2 running Fldigi 3.23.15-02 with Linrad 4.10 and RTL-SDR(tcxo)

Cubieboard 2 running Linrad 4.10 and RTL-SDR(tcxo)

Cubieboard 2
running WSJTx 1.7rc1 , Linrad 4.10 and RTL-SDR(tcxo)

update: 18.November 2016
A tryout with the BananaPi in MSK144 mode on 6m with WSJTx1.7rc2.
It works with analog LINE in audiosignal but CPU load is on the limit.

BananaPi running WSJTx1.7rc2 in MSK144 Mode
If you need more Information write me an email


Back to main page

last change: 28.december 2016 (DG0OPK)